wiki:Installationsanleitung

Version 21 (modified by bbe, 11 years ago) (diff)

--

Diese Seite wurde am 23.2.2007 von http://www.heise.de/ct/ftp/projekte/ct-bot/installationsanleitung.shtml hierher kopiert und ist deshalb in HTML, nicht in Wiki-Formatierung.


Da die Seite irrwitzig lang und unübersichtlich ist, sollten wir über eine bessere Aufteilung nachdenken.

c't-Bot und c't-Sim

Installationsanleitung für den c't-Bot und den c't-Sim

Überblick: Architektur

Auf Software-Seite besteht der c't-Bot in erster Linie aus Steuercode, der von c't-Bot-Bastlern in C geschrieben wird. Dieser bekommt mittels des c't-Bot-Frameworks Daten von den Licht-, Abstands- und sonstigen Sensoren des Bot, und kann Befehle an die Motoren (oder andere Aktuatoren) geben. Der Steuercode repräsentiert also das gesamte Verhalten eines Bots. Er lässt sich auf zwei Arten kompilieren:

  • zur Ausführung auf der realen c't-Bot-Hardware
  • oder zur Ausführung auf einem PC (Linux oder Windows) als virtuellem c't-Bot.
Das letztere ist deshalb interessant, weil man den Steuercode dann an den c't-Sim anbinden kann. Dabei handelt es sich um ein in Java geschriebenes Open-Source-Programm, das unter Federführung der c't-Redaktion entwickelt wird. Es simuliert verschiedene Parcours und die Bots in ihnen, d.h. der c't-Sim berechnet, wie weit die Abstandssensoren des virtuellen Bots von den Parcourswänden entfernt sind, wieviel Licht auf seine Lichtsensoren fällt usw. Der an den c't-Sim angebundene virtuelle Bot bekommt diese Daten ständig per TCP/IP übermittelt und reagiert auf sie, als ob er auf realer Bot-Hardware liefe und Werte von tatsächlichen Sensoren erhielte. Wenn der virtuelle Bot z.B. Befehle an seine Motoren gibt, werden diese an den c't-Sim übermittelt und der virtuelle Bot im Parcours um die entsprechende Strecke weiterbewegt.

Außerdem besteht die Möglichkeit, mehrere virtuelle Bots gleichzeitig mit dem c't-Sim zu verbinden und im Parcours umherziehen zu lassen.

Überblick: Was brauche ich?

  1. In jedem Fall umfasst die vorgeschlagene Entwicklungsumgebung für das Projekt:
  2. Je nach dem, was man tun möchte, ist zusätzliche Software nötig – siehe die folgende Tabelle.
  3. Schließlich wird der Quelltext benötigt, der in dem in der Tabelle angegebenen SVN-Modul bereitsteht. (Wie bekommt man Quelltext aus dem SVN?)
Aufgabe Werkzeuge unter Linux Werkzeuge unter Windows SVN-Modul Eventuell relevant
Bot-Steuercode entwickeln und auf realer Bot-Hardware ausführen ct-Bot
Bot-Steuercode entwickeln und als virtueller Bot im c't-Sim ausführen (Wie startet man c't-Sim?) ct-Bot, ct-Sim  
c't-Sim weiterentwickeln ct-Sim  
c't-Sim-HTML-Dokumentation generieren (Näheres dazu) ct-Sim  
c't-Bot-HTML-Dokumentation generieren ct-Bot  
AVR-spezifischen C-Code debuggen (Was heißt das?) (nicht von uns getestet,
Hinweise willkommen)
ct-Bot  

Dem Programmieradapter Ponyprog zum Übertragen der .hex-Dateien in den Roboter haben wir hier keine eigene Sektion gewidmet, da die Installation keine Probleme bereiten sollte.

Manche Linux-Distributionen bringen von Haus aus bereits das eine oder andere Werkzeug mit; Windows-Nutzer müssen mit Downloads im Gesamtumfang von rund 200 MB rechnen.

Installation des JRE/JDK

Zur Ausführung der fürs c't-Bot-Projekt empfohlenen Entwicklungsumgebung Eclipse und des c't-Sim ist eine Java-Laufzeitumgebung (Java Runtime Environment, JRE) in der Version 5.0 oder höher erforderlich. Falls der Sim darüber hinaus auch weiterentwickelt werden soll, ist das Java Development Kit (JDK) 5.0 nötig. Das JDK enthält das JRE, sodass in jedem Fall nur eine Installation zu erledigen ist.

Bei Sun sind sowohl JRE als auch JDK erhältlich. Einige Linux-Distributionen zählen aus lizenzrechtlichen Gründen andere Java-Implementierungen zu ihrem Standard-Repertoire. Diese erfüllen allerdings teilweise nicht den kompletten Java-Standard 1.5 – funktioniert c't-Sim in einer solchen alternativen Java-Umgebung nicht richtig, wird empfohlen, auf das JDK von Sun auszuweichen.

Zurück zum Überblick

Installation von Java3D

Für die Anzeige der virtuellen Welt benötigt der c't-Sim das Paket Java3D 1.4.0.

Java3D steht als Installer oder als Archiv verpackt im Netz. Im letzteren Fall extrahiert man den Inhalt in das Unterverzeichnis „jre“ des Java-JDK-Verzeichnisses. Eventuell warnt hierbei der Rechner, im Zielverzeichnis seien die Verzeichnisse „bin“ und „lib“ bereits vorhanden – es besteht hierbei allerdings keine Gefahr, dass wichtige Dateien überschrieben werden.

Damit Elemente aus Java3D richtig angezeigt werden können, muss der Treiber der Grafikkarte den Standard OpenGL 1.3 oder höher unterstützen.

Zurück zum Überblick

Installation von Eclipse

Was ist Eclipse? Für Experimente am Code des Simulators und des Bots bietet sich die Entwicklungsumgebung Eclipse an, da sie einerseits Java unterstützt für Weiterentwicklung des c't-Sim und andererseits C für Entwicklung von Bot-Steuercode. Eclipse selbst ist in Java geschrieben und läuft daher unabhängig von der Rechnerplattform. (Warum Eclipse und keine andere IDE?)

Zur Installation lädt man Eclipse als Zip-Datei herunter und entpackt sie. Eine weitere Installation entfällt; die ausführbare Datei eclipse(.exe) startet direkt die Entwicklungsumgebung auf Java-Basis. Eclipse legt ein Arbeitsverzeichnis namens „Workspace“ an, dessen Ort der Nutzer selbst bestimmen kann.

Wichtig: In Eclipse muss im Menü „Window/Preferences“ bei „Java/Compiler/JDK Compliance“ die Version 5.0 aktiviert werden, ansonsten meldet der Code des c't-Sim beim Übersetzen Kompilierfehler.

Zurück zum Überblick

Erzeugen der Dokumentation mit Javadoc

Der Quelltext des c't-Sim ist ausführlich dokumentiert. Aus den Kommentaren im Source kann man bequem durchsuchbare HTML-Seiten generieren. Für den Java-Code benutzt man dazu das Tool Javadoc, das zum Lieferumfang des JDK gehört. Unter dem Eclipse-Menüpunkt „Project/Generate Javadoc“ trägt man bei „Javadoc command“ den Pfad zum Programm javadoc(.exe) ein, das sich im Unterverzeichnis bin des JDK befindet. Die fertigen HTML-Seiten können in einen beliebigen Ordner geschrieben werden, voreingestellt ist das Unterverzeichnis „doc“ des Java-Projekts ct-Sim.

Erzeugen der Java-Dokumentation

Zurück zum Überblick

Installation von Eclipse-Plugins

Eclipse-Plugins können auf zwei gleichwertige Arten installiert werden:

  • Man kann die Zip-Datei mit dem Plugin herunterladen und sie ins Eclipse-Verzeichnis extrahieren, was typischerweise einige Dateien zu den Unterverzeichnissen „features“ und „plugins“ hinzufügt.
  • Die Alternative ist, eine „Update URL“ von der Seite des Plugins zu kopieren, die in Eclipse dann unter dem Menüpunkt „Help/Software Updates/Find and Install/Search for new features to install“ als „New remote site“ eingefügt wird – siehe Screenshot. Der Vorteil dieser Methode ist, dass auch zukünftige Updates über „Help/Software Updates“ automatisch installiert werden können, wenn man Eclipse einmal mit der Update URL bekanntgemacht hat. Unter „Window/Preferences/Install and Updates“ kann ein Proxy-Server eingestellt werden, wenn die Internetverbindung einen solchen erfordert.

No image "plugins.jpg" attached to Installationsanleitung

Zurück zum Überblick

Installation des CDT

Was ist das CDT? Das Plugin CDT (C Development Toolkit) rüstet Eclipse um Unterstützung für Entwicklung in C auf, da Eclipse von Haus aus kein C spricht.

Die Installation nimmt man am besten über den in Eclipse integrierten Update-Mechanismus vor. Das CDT wird als Teil des Callisto-Projekts veröffentlicht, daher geht man folgendermaßen vor:

  • „Help/Software Updates/Find and Install/Search for new features to install“
  • „Next“
  • „Callisto Discovery Site“
  • „Finish“
  • Nach kurzer Zeit meldet sich das Ergebnisfenster.
  • „Callisto Discovery Site/C and C++ Development/Eclipse C and C++ development tools“
  • „Next“
  • „I accept“, „Next“
  • „Finish“
  • Während der Installation muss noch der Dialog „Feature Verification“ bestätigt werden („Install“)
  • Nach der Installation fragt Eclipse, ob es sich neu starten soll („Yes“)

Zurück zum Überblick

c't-Sim inkl. virtueller Bots starten

  1. Gemäß Überblick die nötige Software installieren und den betreffenden Quelltext auschecken
  2. c't-Sim starten. Hierzu gibt es drei gleichwertige Möglichkeiten:
    • In Eclipse klickt man die Datei ctSim/controller/Controller.java rechts an und wählt „Run As/Application“. (Tipp: Nach dem ersten „Run“ startet Strg-F11 die zuletzt ausgeführte Datei.)
    • Von der Kommandozeile aus wechselt man in das Verzeichnis, in dem Eclipse das ctSim-Projekt aufhebt (ein Unterverzeichnis des Eclipse-Workspace, den man bei der Eclipse-Installation angegeben hat). Dort: java ctSim.controller.Controller
    • Zum möglichst bequemen Start in Zukunft kann man ein Jar-Archiv erzeugen (Details siehe FAQ).
  3. Falls nicht schon geschehen, c't-Bot kompilieren (ct-Bot-Projekt markieren und „Project/Clean“ wählen)
  4. c't-Bot starten:
    • In Eclipse im ctBot-Projekt die Datei Debug-Linux/ctBot.elf (Linux) bzw. Debug-W32\ctBot.exe doppelt anklicken
    • Auf der Kommandozeile Wechsel in das Verzeichnis, in dem Eclipse das ctBot-Projekt aufhebt, und die eben genannte Datei ausführen

Hinweis: Die Datei ct-Bot.exe bzw. ct-Bot.elf beendet sich zügig wieder, wenn sie keinen Simulator findet, der auf ihren Versuch einer TCP/IP-Verbindung antwortet. Daher ist die Reihenfolge „zuerst Sim, dann Bot“ wichtig.

Zurück zum Überblick

Installation der AVR-binutils (Linux)

Wer auch für den ATmega644 Code übersetzen will, sollte binutils ab Version 2.17 verwenden.

  1. binutils herunterladen und auspacken (tar jvxf binutils-42.42.42.tar.bz2)
  2. cd binutils-42.42.42
  3. mkdir obj-avr
  4. cd obj-avr
  5. ../configure --target=avr --prefix=/usr/local/avr --disable-nls
  6. make && make install
  7. Linux-Pfad erweitern: export PATH=$PATH:/usr/local/avr/bin

Zurück zum Überblick

Installation des AVR-gcc (Linux)

Wer auch für den ATmega644 Code übersetzen will, sollte einen gcc ab Version 4.1.1 verwenden und muss den "New-Devices-Patch vor dem Übersetzen des gcc einspielen (Punkte 3 und 4). Wer nur für den ATmega32 aus dem Standardbausatz Code entwickelt, kann die Punkte 3. und 4. überspringen.

  1. gcc herunterladen und auspacken (tar jvxf gcc-core-42.42.42.tar.bz2)
  2. cd gcc-core-42.42.42
  3. den new-devices-Patch herunterladen
  4. Den new-devices-Patch einspielen: patch -p 0 < DATEINAME_DES_PATCHES
  • mkdir obj-avr
  • cd obj-avr
  • ../configure --target=avr --prefix=/usr/local/avr --disable-nls --enable-language=c
  • make && make install
  • In Eclipse kann man jetzt nach Rechtsklick auf das Projekt unter „Active Build Configuration“ das Target Debug-MCU-Linux auswählen. Falls das nicht kompiliert, weil Eclipse avr-gcc nicht findet, muss der avr-gcc entweder zur Path-Variablen des Systems hinzugefügt werden (Eclipse neustarten!) oder eingestellt werden unter „Project/Properties/C C++ Build/Debug-MCU-Linux/Tool Settings“, Unterpunkte „GCC C Compiler“ und „GCC C Linker“.
  • Zurück zum Überblick

    Installation der AVR-libc (Linux)

    Wer auch für den ATmega644 Code übersetzen will, sollte AVR-libc ab Version 1.4.4 verwenden.

    1. avr-libc herunterladen und auspacken (tar jvxf avr-libc-42.42.42.tar.bz2)
    2. cd avr-libc-42.42.42
    3. ./configure --prefix=/usr/local/ --host=avr
    4. make && make install

    Zurück zum Überblick

    Installation des gcc (Linux)

    Der gcc gehört zur Grundausstattung jeder Linux-Distribution, wird aber nicht unbedingt bei jeder Installation auf dem System eingerichtet – gegebenenfalls muss er über den Paketmanager der jeweiligen Distribution nachinstalliert werden.

    Zurück zum Überblick

    Installation des gcc inkl. Unix-Umgebung (Windows)

    Einführung: Eine Windows-Version des C-Compilers gcc wird von dem kostenlosen Paket MinGW zur Verfügung gestellt. Erforderliche Zusatzwerkzeuge kommen im MinGW-Zusatzpaket MSYS. Unix-kompatibles Threading nach dem Posix-Standard wird von der Bibliothek Pthreads zur Verfügung gestellt. In der Summe kann mit dieser Umgebung derselbe in C geschriebene Bot-Steuercode, der unter Linux funktioniert, auch unter Windows kompiliert und ausgefürt werden.

    Installation:
    1. MinGW 5.0.0 herunterladen und ausführen. Wichtig: Das Häkchen, um „MinGW-make“ zu installieren, muss gesetzt sein. (Typischer Installationsort: C:\Programme\MinGW)
    2. MSYS 1.0.10 herunterladen und ausführen
    3. Das „bin“-Verzeichnis von MSYS zur Path-Variablen des Systems hinzuzufügen. (MinGW sollte sein bin-Verzeichnis bei der Installation automatisch zum Pfad hinzugefügt haben. Für MSYS muss das von Hand erledigt werden: Im Dialog „Systemsteuerung/System“ (erreichbar über Windowstaste+Pause) unter „Erweitert“ den Knopf „Umgebungsvariablen“ drücken. Zur Variablen „Path“ ist der Pfad zu MSYS' „bin“-Verzeichnis hinzufügen – standardmäßig C:\msys\1.0\bin.)
    4. Pthreads 2.7.0 herunterladen und entpacken (Typischer Installationsort: C:\Programme\pthreads). Dort im Unterverzeichnis „lib“ die Datei „pthreadGC2.dll“ finden und ins Verzeichnis C:\windows\system32 kopieren.

    Zurück zum Überblick

    Installation von WinAVR (Windows)

    Alle benötigten Programme befinden sich fertig übersetzt im Paket WinAVR 20060421. Nach der Installation muss man höchstens noch die entsprechenden Pfade im Eclipse-Build-Target Debug-MCU-W32 anpassen. (Hierzu unter „Project/Properties/C C++ Build/Debug-MCU-W32“ die Pfadeinstellungen anpassen unter „Tool Settings/GCC C Compiler“, „Tool Settings/GCC C Linker“ sowie „Build settings/Build command“.)

    Zurück zum Überblick

    Einrichten des USB-2-Bot-Adapters

    Wer noch alte D2XX-Treiber installiert hat, sollte diese zuallererst entfernen. Die ursprünglich von uns vorgeschlagene Kommunikation über die JD2XX-Bibliothek und den D2XX-Treiber für Windows erforderte Klimmzüge unter Linux und harmonierte nicht mit anderen Adaptern zum c't-Bot. Daher haben wir nun die Kommunikation mit tatkräftiger Unterstützung einiger Leser auf die RXTX-Bibliothek umgestellt.

    Steckt man den USB-2-Bot-Adapter zum ersten Mal an einen Windows-PC, so fragt Windows nach einem Treiber. Hier gibt man den VCP-Treiber an, der einen virtuellen COM-Port einrichtet. Aktuelle Linux-Kernel erkennen den FTDI-Chip bereits von Haus aus und machen ihn über /dev/ttyUSB0 zugänglich.

    Damit Java auf den Port zugreifen kann, haben wir die RXTX-Bibliothek in den c't-Sim-Quelltext aufgenommen:

    Die Binaries für Windows, Linux und Mac OS X und Solaris stehen im Code-Archiv im Verzeichnis contrib/rxtx bereit. Sie müssen nur noch an den richtigen Ort:

    Windows:
    Die Datei contrib\rxtx\Windows\i386-mingw32\rxtxSerial.dll kommt in das Verzeichnis JAVA_HOME\jre\bin.

    Linux:
    Die Datei contrib\rxtx\Linux\i686-unknown-linux-gnu\librxtxSerial.so kommt in das Verzeichnis JAVA_HOME/jre/lib/i386. Des Weiteren muss der Benutzer, der später den Sim startet Mitglied in einer Gruppe sein (einstellbar über /etc/group), die Lockfiles schreiben darf (z.B. lock oder uucp).

    Anleitungen für weitere Betriebssysteme finden sich in der Datei contrib/rxtx/INSTALL.

    über welchen COM-Port und mit welcher Geschwindigkeit der Bot erreichbar ist, teilt man dem c't-Sim in der Datei config/ct-sim.xml mit. Für Windows (Welchen Port man eintragen muss, verrät der Gerätemanager) sieht das wie folgt aus:

       <parameter name="serialport" value="COM1"/>
       <parameter name="serialportBaudrate" value="9600"/>
    

    Für Linux sieht die Config-Datei ungefähr so aus:

       <parameter name="serialport" value="/dev/ttyUSB0"/>
       <parameter name="serialportBaudrate" value="9600"/>
    

    Zurück zum Überblick

    Installation von Doxygen

    Ähnlich wie es Javadoc für Java-Code tut, extrahiert das Programm Doxygen Kommentare aus C-Quelltext. Unter Linux gehört dieses Tool zur Standardinstallation oder ist per Paketmanager installierbar; Windows-Nutzer können es per Installationsprogramm nachrüsten.
    Ein ebenfalls nettes und nützliches Tool ist Graphviz (bei Linux ebenfalls meist installiert). Doxygen beutzt es, um Zusammenhänge im Code grafisch darzustellen. Unter Windows muss man es selbst installieren.

    Zurück zum Überblick

    Installation von Eclox

    Als Frontend dient das Eclipse-Plugin Eclox, das installiert werden kann per Zip-Datei oder per Update URL: http://download.gna.org/eclox/update/ – Zur Installation von Eclipse-Plugins siehe oben.

    Nach der Installation von Eclox muss man in Eclipse unter „Window/Preferences“ für „Doxygen/Compiler Path“ den Pfad zum Programm „doxygen“ eintragen.

    No image "doxygen.jpg" attached to Installationsanleitung

    Zurück zum Überblick

    AVR-spezifischen C-Code debuggen

    Zusammenfassung: Debuggen auf dieser Ebene ist nur in seltenen Spezialfällen erforderlich.

    Der C-Code, der insgesamt c't-Bot genannt wird, hat drei Komponenten:

    • High-Level-Anteile (inkl. von Lesern entwickeltem Bot-Steuercode), die z. B. Sensorwerte zugestellt bekommen und auf sie reagieren. Derselbe High-Level-Code läuft sowohl auf dem PC um einen virtuellen Bot in einer vom c't Sim simulierten Welt zu steuern, als auch auf der AVR um einen in Hardware realisierten Bot zu steuern.
    • PC-Low-Level-Teile, die auf dem PC ausgeführt werden und z.B. (simulierte) Sensorwerte per TCP vom c't-Sim lesen und an den High-Level-Code weiterreichen
    • AVR-Low-Level-Teile, die vom Mikrocontroller des in Hardware realisierten Bot ausgeführt werden und z.B. Sensorwerte von den Hardware-Sensoren lesen und an den High-Level-Code weiterreichen.

    Der AVR-gdb dient nun dazu, diesen letzteren Teil des C-Codes debuggen zu können – und zwar in einer auf dem PC laufenden, vom <;;;;;;;;;a href="#simulavr">Simulavr

    -Paket bitgenau emulierten Umgebung. Das ist hilfreich in den (wenigen, speziellen) Fällen, wo es nicht m&;ouml;glich oder zu unbequem ist, Debuginformationen auf dem Display des Roboters auszugeben. Bisher haben wir das nur unter Linux ausprobiert; unter Windows sollte es jedoch analog funktionieren.

    Zurück zum Überblick

    Installation von Simulavr (Linux)

    Einführung: Wofür sind Simulavr und der AVR-gdb?

    Installation:

    1. Simulavr herunterladen und auspacken (tar jvxf simulavr-42.42.42.tar.bz2)
    2. cd simulavr-42.42.42
    3. ./configure --prefix=/usr/local/avr --with-avr-includes=/usr/local/avr/avr/include
    4. make
    5. Eventuell braucht man noch die devel-Version des curses-Pakets der jeweiligen Linux-Distriubution
    6. Eventuell muss man in der Datei configure folgende Zeile verändern:

      ENABLE_WARNINGS="-Wall -Winline -Werror"

      sie sollte lauten:

      ENABLE_WARNINGS="-Wall -Winline"

      danach ruft man make distclean auf und beginnt wieder mit dem configure-Kommando wie oben

    7. make install

    Zurück zum Überblick

    Installation des AVR-gdb (Linux)

    Einführung: Wofür sind Simulavr und der AVR-gdb?

    Installation:

    1. gdb 6.4 herunterladen und auspacken (tar jvxf gdb-42.42.42.tar.bz2)
    2. cd gdb-42.42.42
    3. ./configure --target=avr --prefix=/usr/local/avr
    4. Die Release-Version 6.4 harmoniert noch nicht mit Eclipse. Daher entweder die aus dem CVS verwenden, oder die Datei solib.c editieren.

      In der Funktion:

      static void
      info_sharedlibrary_command (char *ignore, int from_tty)
      

      folgende 3 Zeile suchen:

       else if (TARGET_PTR_BIT == 64)
          addr_width = 16 + 4;
      else
      
      

      und ersetzen durch:

       else if (TARGET_PTR_BIT == 64)
          addr_width = 16 + 4;
        else if (TARGET_PTR_BIT == 16) {
          printf_unfiltered (_("No shared libraries on 8-Bit-Platforms.\n"));
              return;
        }else
      
    5. make
    6. Unter umständen muss man noch die termcap-Bibliothek der jeweiligen Distribution nachinstallieren)
    7. make install

    AVR-gdb in Eclipse einbinden:

    1. In Eclipse unter „Run/Debug“ ein neues Debug-Target für den Mikrocontroller anlegen. Es sollte folgende Eigenschaften haben:

      • C/C++ Local Application
      • Main
        • Project: ct-Bot
        • C/C++ Application: Debug-MCU-Linux/ct-Bot.elf oder Debug-W32-Linux/ct-Bot.elf
      • Debugger
        • GDB Debugger: /usr/local/avr/bin/avr-gdb oder ähnlich
        • GDB Command File: gdb-run
    2. Eventuell jammert Eclipse noch ein wenig, das es zu dem Prozessor keinen passenden Compiler hat, aber das kann man getrost ignorieren.

    Emulator starten: Damit nun der AVR-gdb, der von Eclipse aufgerufen wird, den Code in der AVR-Umgebung ausführen kann, muss Simulavr im Hintergrund laufen:

    1. In einer Shell startet man simulavr -g -p 1212 -d atmega16 -P simulavr-disp -c 16000000

    Leider kennt die aktuelle Version des AVR-Simualtors (0.1.2.2) den auf dem Bot verwendeten ATmega32 noch nicht, so dass man sich mit dem Pin- und Code-kompatiblen ATmega16 behilft. – Achtung, der hat weniger Speicher! Bei Problemen sollte man das auch dem Compiler und dem Linker in den Projekt-Einstellungen mitteilen. Alternativ dazu haben wir auf der Simulavr-Seite bereits einen Patch für ATmega32-Unterstützung eingereicht.

    Zurück zum Überblick

    Download des Codes aus dem SVN

    Diese Sektion der Installationsumleitung ist bereits in das SVN-Howto umgezogen.

    Zurück zum Überblick

    Alternative: Import des Codes aus Zip-Archiven

    Wir empfehlen, den Code für c't-Bot und c't-Sim aus dem CVS zu benutzen -- dieser befindet sich stets auf dem neuesten Stand. Falls Sie nicht auf das SVN zugreifen können (etwa weil Ihr Rechner durch eine Firewall vom Internet abgeschottet ist, welche die notwendigen Ports geschlossen hält), können Sie auf den Code aus Zip-Archiven auf unserem Server zurückgreifen. Solche Archive bringen wir allerdings nur bei umfangreicheren Änderungen auf den neuesten Stand, nicht für jedes kleine Bugfix, deshalb ist der Code im Zip-Archiv eventuell älter als jener im SVN.

    Wenn Sie trotzdem auf das Zip-Archiv zugreifen wollen oder müssen, laden Sie es sich auf den eigenen Rechner und packen es aus. Nach dem Start von Eclipse kann unter dem Menüpunkt File / Import die Option Existing Project into Workspace ausgewählt werden. Als root directory muss dann der Ordner ct-Sim oder ct-Bot angeben werden.

    Zurück zum Überblick

    Attachments (2)

    Download all attachments as: .zip