Menü
Avatar von biologist
  • biologist

mehr als 1000 Beiträge seit 08.12.2006

Re: Wieder ein Teil, was (k)einer braucht.

Ja, sind sie auch.
Bei mir war es so, dass ich einen Raspi jetzt jahrelang im Gartenhaus hatte, er war dort primär für die Steuerung der Gartenbewässerung und dem Auslesen von Sensoren zuständig. Es liefen aber auch Dienste wie openHAB und piHole drauf. Insofern wars schon so, dass ich den auch brauchte. Naja, jetzt habe ich für eine Wetterstation (Raspi mit Display) den Raspi reingeholt (in Wirklichkeit habe ich natürlich mehr als einen davon) und dann überlegt, ob man die Außenstelle nicht auch mit einem Mikrocontroller anbinden kann. Habe mich dann für einen ESP8266-12E auf nem Entwicklerboard entschieden. Der Kram kostet ja fast nix - selbst in .de keine fünf Euro für so ein Board. Das Ding misst alle fünf Minuten mehrere Sensoren, pusht diese via MQTT (über WLAN) und pennt dann wieder, sofern ich das per Software-Schalter in openHAB nicht untersage. Das dauert jeweils so 5s. D.h. von den 300s braucht das Ding 295s lang 1,6 mA und sonst im Mittel so 72 mA. Das sind im Mttel nicht mal 14 mW. Dazu kommen nochmal ca. 130 mW Standby-Verluste des Netzteils. Umgeht man den Festspannungsregler und geht gleich auf 3.3V vom Netzteil, lässt sich nochmal was sparen. Im Sommer wird zur Gartenbewässerung das Ding natürlich nicht ständig im DeepSleep sein, da es ja sofort reagieren soll und nicht in "bis zu" fünf Minuten. Aber dennoch: Mehr als 2 kWh/a werden es nicht werden. Heise schrieb bei nem Raspi 3b mal was von 2W (inkl.) Netzteil - das sind dann schon 17 kWh.

Überrascht war ich übrigens kürzlich, wieviel Strom ein Ethernet-Board zieht. Und zwar habe ich Lampen an der Fassade, die ich gerne auf Basis von Astro bzw. Helligkeitssensor einschalten würde. Das habe ich auch jahrelang nicht gemacht, weil mir ein Raspi zu schade dafür war. Das realisiere ich jetzt mit einem Arduino und da das im Keller in der Hauptverteilung ist, habe ich dort kein WLAN. Idee war eigentlich, dass der Arduino pennt und dann vom EthBoard (W5500) per Wake-on-Lan aufgeweckt wird. Bis ich dann feststellte, dass der Arduino nano ca. 14,5 mA zieht, inkl. EthBoard dann aber 127 mA (!). Mit fester Reduktion auf 10M (statt 100M) konnte ich es auf 84 mA senken. Aber selbst im PowerDown-Modus des EthBoards sind es ingsesamt noch 47 mA. Beide Boards schlafend habe ich noch nicht gemessen, denke aber mal, dass es paarunddreißig mA werden. Wie auch immer: Viel kommt da übers Jahr gesehen nicht zusammen - Batteriebetrieb habe ich hier ja keinen.

Bewerten
- +
Anzeige