Avatar von Jörk Barkow
  • Jörk Barkow

2 Beiträge seit 08.12.2017

Installationsskript, das Container passend erweitert?

Smart Home: Blauzahnerkennung- c't 4/2019 S. 162

Hallo,

ich versuche node-red-contrib-noble zu installieren. Nutze die noderedpack - Installation von der c't auf meinem Raspberry Pi 3.

>Linux pi3 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux

-----------------im Artikel steht
Installation
Wenn Sie unserer Anleitung [1] gefolgt sind und Node-Red im Docker-Container installiert haben, finden Sie über ct.de/yujd ein Installationsskript, das Ihren Container passend zu diesem Artikel erweitert.
---------------------------------

Hat einer von Euch das Installationskript gefunden?

Ich leider nicht - habe mich dann selbst mal versucht.

>docker-compose exec --user root nodered apt-get update
>docker-compose exec --user root nodered apt-get install -y libbluetooth-dev

Änderungen geschrieben mit docker commit und alles mal durchgestartet.

In den Logs finde ich folgende Warnung

....
nodered_1 | 2 Feb 21:44:59 - [warn] ------------------------------------------------------
nodered_1 | 2 Feb 21:44:59 - [warn] [node-red-contrib-noble/noble] Error: Cannot find module 'bluetooth-hci-socket'
nodered_1 | 2 Feb 21:44:59 - [warn] ------------------------------------------------------
....

> docker-compose exec --user root nodered npm install bluetooth-hci-socket

Bricht bei mir mit Fehlern ab. Ist einer von Euch weiter?

Bewerten
- +
Anzeige