Avatar von Lonzo32
  • Lonzo32

4 Beiträge seit 13.06.2015

Workaround für node-red-contrib-noble unter node.js v10 (RPi):

Hallo,

sowohl noble als auch bluetooth-hci-socket werden als abandonware weitergeführt. So ist es mir gelungen, node-red-contrib-noble unter node.js v10 zu installieren:

cd .node-red/node_modules/ git clone https://github.com/kmi/node-red-contrib-noble.git

package.json editieren und die dependency von noble auf @abandonware/noble ändern und noble/node-red-contrib-noble.js ebenfalls anpassen

diff --git a/noble/node-red-contrib-noble.js b/noble/node-red-contrib-noble.js index c6a8a2e..b7870ed 100644 --- a/noble/node-red-contrib-noble.js +++ b/noble/node-red-contrib-noble.js @@ -23,7 +23,7 @@ module.exports = function(RED) { "use strict"; - var noble = require('noble'); + var noble = require('@abandonware/noble'); var os = require('os'); // The main node definition - most things happen in here diff --git a/package.json b/package.json index dc9c240..ee0dbb0 100644 --- a/package.json +++ b/package.json @@ -3,7 +3,7 @@ "version": "0.3.0", "description": "A Node-RED node that uses Noble to interact with BLEs", "dependencies": { - "noble": ">=0.2.7" + "@abandonware/noble": "latest"

anschließend installieren

npm install

und freuen. Grüße!

Das Posting wurde vom Benutzer editiert (19.04.2019 12:57).

Bewerten
- +
Anzeige