c't Hilfe-Forum
Alle Heise-Foren > c't > c't Hilfe-Forum > hartnäckiges Problem mit RAID1
Avatar von Senfmensch
  • Senfmensch

6 Beiträge seit 08.01.2012

hartnäckiges Problem mit RAID1

Hallo! Ich brauche dringend und endlich mal Hilfe: Und zwar habe ich
seit längerem ein großes Problem mit meinem RAID1-Verbund. Es fing
alles an, alles eine meiner alten Festplatten des alten Verbundes den
Geist aufgab und ich mir daraufhin zwei neue, schnellere mit größerer
Kapazität gekauft habe (zwei WD800AAJ von Western Digital). Den alten
RAID-Controller habe ich gegen einen DC-4320 von Dawicontrol mit
Silicon Image Sil 3124 Chip ausgetauscht.

Ich habe mit diesem Controller die Möglichkeit

a) ein BIOS von Dawicontrol mit einem RAID-Verwaltungsprogramm für
Windows von Dawicontrol (RAID Monitor)

b) ein BIOS von Dawicontrol mit einem RAID-Verwaltungsprogramm für
Windows von Silicon Image (SATARAID5Manager)

c) ein BIOS von Silicon Image mit einem RAID-Verwaltungsprogramm für
Windows von Silicon Image

d) ein BIOS von Silicon Image mit einem RAID-Verwaltungsprogramm für
Windows von Dawicontrol

zu benutzen.

Zu Beginn war Variante c) eingerichtet. Schon sehr bald, nachdem die
Daten des alten Verbundes übertragen waren, bekamm ich vom
"SATARAID5Manager" die Meldung "Status Reduced", symbolisiert durch
zwei statt grün- nun gelbgefärbten Festplattensymbolen. Beim nächsten
Hochfahren erhielt ich vom BIOS die Meldung, dass das Set
wiederhegestellt werden müsse. Das ist in den nächsten Wochen/Monaten
mehrmals der Fall gewesen und hat immer etwa 2-3 Stunden gedauert. Da
das das BIOS gemacht hat, fand das stets VOR dem Hochfahren statt.
Der Computer war während dieser Zeit also nicht für etwas Anderes zu
benutzen. Nachvollziehbarer Weise hat das stark genervt. Trotz
intensiver Suche, konnte ich per Internet keine Lösung für dieses
Problem finden. Also war das alle paar Wochen ein notwendiges Übel.
Später dann, habe ich statt des SI-BIOS das DC-BIOS aufgespielt und
hatte seitdem das Phänomen, dass, wenn der "SATARAID5Manager" einen
"Status Reduced" gemeldet hat, beim nächsten Hochfahren das DC-BIOS
"Metadata updated" meldetete und im "SATARAID5Manager" die
Festplattensymbole wieder grün waren. Ich war fürs Erste beruhigt und
hielt das für einen akzeptablen Zwischenzustand. Schließlich fiel so
das zeitraubende und nervende Synchronisieren weg. Irgendwann habe
ich der Sache aber nicht mehr ganz trauen wollen und wieder
angefangen herumzuexperimentieren.

So, ab hier kann ich ehrlich gesagt nicht mehr genau rekonstruieren,
was in welcher Reihenfolge passiert ist :-)

Jedenfalls habe ich irgendwann den Dawicontrol RAID-Monitor
installiert, mit dem ich die Synchronisationen nebenher unter Windows
laufen lassen konnte. Auch konnte ich mit diesem bequem neue
BIOS-Versionen aufspielen. Ab einem gewissen Zeitpunkt ging die
Synchronisation (vor dem Hochfahren wie auch unter Windows) nur noch
EXTREM langsam vonstatten. So langsam, dass man es jedesmal nur noch
abbrechen konnte, weil es sonst eine gefühlte Ewigkeit gedauert
hätte. Soweit ich mich erinnere, habe ich die Synchronisationen, die
VOR dem Hochfahren liefen, per Neustart abbrechen müßen, weil das per
Tastendruck nicht ging. Unter Windows konnte ich das per Klick auf
einen Schalter. Jedenfalls habe ich daraufhin unter DOS bzw. unter
einer per CD geladenen abgespeckten Linux-Umgebung erneut das DC-BIOS
drübergeladen, in der Hoffnung, dass das das Problem beheben würde,
was leider nicht der Fall war. Seitdem steht meine Datensicherheit
lediglich auf einem Bein, weil bis heute nur eine der
RAID-Festplatten sämtliche Daten enthält. Die andere ist ja
asynchron. Synchronisieren kann ich sie nicht mehr, da dies zu lange
dauert und, nach wie vor, ja regelmäßig stattfinden müßte, da der
RAID-Status nach ein paar Wochen immer wieder in den Status "Reduced"
fällt. Ich sichere zwar relativ regelmäßig sämtliche Daten des
RAID-Verbundes auf eine externe Festplatte, und fühle mich deswegen
immer noch einigermaßen sicher, ruhig schlafen lässt mich dieser
Zustand allerdings nicht.

Dies ist die einzige Seite die ich, trotz intensiver Suche, je zu
diesem Thema gefunden habe:
http://www.administrator.de/index.php?content=75022

Leider konnten die Lösungsvorschläge dort, mein eigenes Problem NICHT
lösen.

Mit großer Bitte um Hilfe oder Vorschläge jedweder Art!

1.) Warum läuft die Synchronisation mittlerweile so extrem langsam
ab?

2.) Warum fällt der synchrone RAID-Verbund sehr bald stets in den
Status "Reduced"?

Vielen Dank im voraus für alle Beiträge!

Bewerten
- +
Anzeige