Avatar von Christian Stieber
  • Christian Stieber

mehr als 1000 Beiträge seit 10.01.2000

Immerhin hat Debian...

... in einem der aktuelleren Zweige die 3.1. Da gibt es vielleicht
bald auch die 3.2.

Im Default-Zweig ist übrigens 2.7 "aktuell"... die kann noch nicht
viel C++11. Falls sie überhaupt schon C++ kann.

Irgendwann muß ich die Distribution doch mal updaten; es fühlt sich
halt einfach falsch an eine Distribution zu installieren die
freiwillig (und nicht als Spitzname) schon "unstable" oder
"experimental" heisst... aber dank clang++ und g++ kann ich derzeit
kein Asterisk ausprobieren: aktuellere Compiler wollen eine aktuelle
libstdc++, Asterisk hat ein Modul nur als Sourcecode, der
module-assistant will gcc 4.3, und gcc 4.3 läßt sich nicht
installieren weil er mit der aktuellen libstdc++ in Konflikt steht.

Und clang++ ist ja nicht das einzige was ich aktueller habe als das
antike Standard-Zeugs :-( Und bei manchen Sachen kann ich nix
aktuelles installieren weil sie dann eine neuere libc haben wollen
was dann das gesamte System hochzieht. Da kann ich auch gleich
offiziell "unstable" oder so werden.

Nicht daß "stable" irgendwas aussagen würde; das Zeug ist genauso
verbugged wie die jeweiligen Upstream-Versionen :-) Insofern werden
sie wohl auch "unstable" nicht mehr als sonst verwanzen...

Christian

Bewerten
- +