Menü
Avatar von Mov Faltin
  • Mov Faltin

mehr als 1000 Beiträge seit 11.12.2013

Nanu? Let's-Encrypt-Service akzeptiert keine eigenen Schlüssel?

Liebes Forum,

vielleicht bin ich bloß zu doof, aber: Es gibt unter https://zerossl.com/free-ssl/ ein webbasiertes Angebot zur Erstellung von Let's-Encrypt-TLS-Zertifikaten. Nachdem bei mir gethttpsforfree.com nach einer emsigen Kopiererei und Einfügerei nicht funktioniert hat ("LE-nonce not found" oder so, hat halt zu lange gebraucht), probiere ich jetzt gerade mal zerossl.com aus.

Und hier bräuchte ich Eure Hilfe:

Ich habe natürlich keinen Bock, mir von irgendeiner Internetseite meinen Let's-Encrypt-Privatschlüssel erstellen zu lassen, und deshalb habe ich einen eigenen RSA-Schlüssel erstellt und daraus dann einfach einen öffentlichen Schlüssel kreiert und dort eingefügt. Und zwar so:

openssl genrsa 4096 > PrivSchluessel.key

bzw. dann den öffentlichen Schlüssel gebaut:

openssl rsa -in PrivSchluessel.key -pubout > OeffSchluessel.pub

...und den Inhalt rüberkopiert. Wenn ich jetzt nicht plötzlich total blöd geworden bin, sollte das eigentlich genau so gehen (ist ja nicht das erste Mal). Aaaber: Die Webseite ZeroSSL teilt mir mit, der RSA-Key sei im falschen Format.

Please use a valid 2048/4096 bits RSA key

Wisst Ihr, woran das liegt? Wenn ich nicht so gutgläubig wäre, würde ich ja mutmaßen, dass die Seitenbetreiber ganz einfach Zugriff auf möglichst viele private Schlüssel zu Let's-Encrypt-Konten erlangen wollen und deshalb die Verwendung bereits mitgebrachter Schlüssel faktisch unterbinden, damit man frustriert anbieterseitig generierte Schlüssel nutzen möge. Aber so dreist -- nein, das fällt mir schwer zu glauben.

Könnte mir hier jemand von Euch bitte weiterhelfen und das kurz verifzieren? Ich komme mir ja noch dümmer vor als sonst...

Vielen Dank!
--Mov

Das Posting wurde vom Benutzer editiert (15.03.2018 13:54).

Bewerten
- +
Anzeige