Menü

Heikle Sicherheitslücke in WordPress-Plug-in FancyBox

Sicherheitsforscher haben eine kritische Schwachstelle im FancyBox-Plug-in für WordPress entdeckt. Diese nutzen Angreifer bereits als Einfallstor für Schadcode.

Lesezeit: 1 Min.
In Pocket speichern
vorlesen Druckansicht Kommentare lesen 20 Beiträge

(Bild: Screenshot: WordPress)

Von

Die Sicherheitsexperten von Sucuri haben eine ernst zu nehmende Sicherheitslücke im WordPress-Plug-in FancyBox entdeckt. Das haben sie in ihrem Blog mitgeteilt, nachdem sie auf einen entsprechenden Thread im WordPress-Forum aufmerksam wurden.

Daniel Cid, Gründer und CTO von Sucuri, zufolge können Angreifer die Lücke ausnutzen, um Schadcode in die jeweilige Seite zu injizieren – was aktuell auch schon geschieht. Betroffene Seiten weisen im Zuge dessen einen schadhaften iFrame auf. Cid und seine Kollegen konnten einen derartigen Angriff in den Logdateien ihrer Firewall nachvollziehen:

46.4.76.174 – – [04/Feb/2015:00:25:09 -0500] “POST /wp-admin/admin-post.php?page=fancybox-for-wordpress HTTP/1.1″ 403 4207 INPUTBODY:action=update&mfbfw%5Bext..

Zwischenzeitlich wurde das Plug-in vom WordPress-Team aus dem Portfolio entfernt. Mittlerweile ist eine gepatchte Version online und allen Nutzern wird dringend geraten, das Plug-in zu aktualisieren. Anschließend wird empfohlen, die Nutzersitzung und Berechtigungen zurückzusetzen.

Wer sich nicht sicher ist ob er FancyBox auf einer seiner WordPress-Seiten nutzt, sollte die Ordnerstruktur nach dem Verzeichnis „fancybox-for-wordpress“ durchsuchen. Mit FancyBox passt man die optische Anmutung des Internetauftritts an und bearbeitet etwa Animationen oder legt Bildergalerien an. WordPress zufolge haben das Plug-in derzeit über 600.000 Nutzer heruntergeladen. (des)