json="{"targeting":{"kw":["Funktionen","Wennfehler","Microsoft Excel"],"cms":4597296}}"

Excel: WENNFEHLER-Funktion richtig nutzen

Bei einer Excel-Tabelle mit vielen Daten wird es schnell unübersichtlich. Und Unübersichtlichkeit kann ebenso schnell zu Fehlern führen. Um Fehler schnell korrigieren zu können, gibt es in Excel die WENNFEHLER-Funktion. Wie Sie diese optimal anwenden können, erläutern wir im folgenden Beitrag.

Wie ist die WENNFEHLER-Funktion in Excel aufgebaut?

Die WENNFEHLER-Funktion in Excel dient dazu, Ihre Daten in der Tabelle zu überprüfen. Dazu wird ein zu überprüfender Wert angegeben. Tritt einer der folgenden Fehler auf, spuckt Ihnen die Funktion eine der folgenden Fehlermeldungen aus: #N/a, #Value!, #ref!, #DIV/0!, #Num!, #Name? oder #NULL!. Die Meldung erfolgt dabei über einen Benachrichtigungstext, den Sie selbst festlegen können. Wenn kein Fehler vorliegt, wird Ihnen stattdessen das Ergebnis der entsprechenden Daten angezeigt.

Die Formel für die Funktion ist wie folgt aufgebaut:

=WENNFEHLER(Wert;Wert_falls_Fehler)

Die Formel für die WENNFEHLER-Funktion verfügt also über zwei Argumente:

Wert: Hier muss angegeben werden, was auf einen Fehler geprüft werden soll. Sie können beispielsweise Zellen angeben, die eine Rechnung enthalten oder das Ergebnis einer Rechnung darstellen. Außerdem können Sie auch selbst eine Rechnung (mit Zellenbezügen) als Wert einfügen.

Wert_falls_Fehler: Hier geben Sie ein, was angezeigt werden soll, wenn ein Fehler gefunden wurde. Dies kann beispielsweise "Fehler bei der Berechnung" oder einfach "Fehler" sein. Diesen Ausdruck zeigt Ihnen die Funktion dann an, wenn ein Fehler erkannt wurde. Bitte beachten: Sie können Zahlen ohne Anführungsstriche in "Wert_falls_Fehler" eintragen. Für Wörter oder Buchstabenkombinationen müssen Sie in der Formel aber Anführungsstriche setzen. Im Folgenden zeigen wir Ihnen zwei Beispiele:

Beispiel für eine WENNFEHLER-Formel

Beispiel 1

=WENNFEHLER(A1/B1;"Fehler")

Hier wurde die Zelle A1 mit dem Wert 2 durch die Zelle B1 mit dem Wert 1 geteilt. Das Ergebnis ergibt 2 und ist damit nicht fehlerhaft. In Zelle C1 wird also das korrekte Ergebnis dargestellt.


Beispiel 2

=WENNFEHLER(A2/B2;"Fehler")

In diesem Beispiel wird auch wieder der Wert der A-Spalte durch den Wert der B-Spalte geteilt. Allerdings soll diesmal A2 mit Wert 2 durch B2 mit Wert 0 geteilt werden. Durch 0 lässt sich nicht teilen, deshalb wird in Zelle C2 die eingestellte Meldung "Fehler" ausgegeben.


Mehr zum Thema: